Acer Aspire One Cloudbook - A01-131-C7DW - 11.6"

Go down

Acer Aspire One Cloudbook - A01-131-C7DW - 11.6"  Empty Acer Aspire One Cloudbook - A01-131-C7DW - 11.6"

Post by Admin on Mon Jul 10, 2017 2:35 pm

This is near duplicate of my other Acer, except this one only has a 16GB eMMC storage drive, instead of 32GB eMMC. Well it also is cosmetically lot better shape... My first one came with bunch stickers/tape, that left plastic looking not so nice by time I got all the sticky removed. These 16GB versions only produced when first introduced for $20 discount off the 32GB version. Even Acer got clue that win10 wasnt going to work very long on these thanks to the mandatory marketing updates by Microsoft. They would had lot happier customers if they had used a replaceable SSD (minimum of 64GB) and minimum of 4GB RAM.

So I see this one in immaculate cosmetic shape on ebay. Win10 of course is fubar, by looks of error screen, say it was a bad win10 reset. So I snag it for $25. Get it, pretty anticlimactic. Worked fine when I booted it from thumbdrive.

While waiting for it, been experimenting a lot with linux on my 32GB version. This Acer bios (yes, latest updated version) truly hates linux as linux does run ok on HP Stream with nearly identical hardware. If I booted linux in UEFI mode, it would only boot successfully one out of six times. If I booted in legacy mode, it would boot every time IF I put "noapic" on kernel line of GRUB. But it was super slow booting and shutting down. Xubuntu 16.04 for example took like 4 full minutes to boot to desktop. Worked ok once booted. Then shutdown was slow until it would just hang at one point and force a hard shutdown with power button.

Knoppix 7.7 similar. Sparky wouldnt even boot. Tahrpup(one official flavor of Puppy Linux) wouldnt boot. Slacko64 (another official flavor of Puppy Linux) version 6.3 would boot but to a backlighted black screen, some problem with the built in Intel video chip. Then I find a beta version of Slacko64 version, the one with optional linux kernel 4.9.30.

This beta version had to be installed manually, the installer just saw the drive, didnt see partitions, assume this will be fixed before it becomes the standard version of Slacko64. Once installed (frugal instal) with Acer in legacy bios mode, this one booted reliably to desktop in 20 seconds and fully shut down computer in 5 seconds. Whoohoo! Like this was made for this Acer. Takes very little space on the drive, since all compressed files in frugal install. You establish a save file for rest of the drive (I reserved 1GB for swap partition). You have the choice of a save file or save directory. The save file works better for me. Comes with Firefox 52 and LibreOffice. I added Iron Browser 59 (near clone of Chromium 59) which works well. Also Kpet bundle of solitaire games and Sudoku. Anyway made it into a nice little linux computer.

Usual Puppy small size/speed and general Puppy goodness helps, but also give lot credit to the much more recent linux kernel. I think linux is finally starting to better support the all in one multicore Intel atom/celeron stuff now used on the low end laptops and tablets and stick computers.

Does leave me scratching my head what exactly to do with this Acer. Frankly right now computer tinkering has left me quite few spare laptops. The Lenovo has become my downstairs Kindle book. Other than my experimenting, my old P4 desktop probably good enough for most other uses. But hey its been interesting.

What is curious, I've read lot reviews on Amazon of various makes of these mini cheap laptops. I guess lot of them sell just cause of price though anybody knowledgable on prices of used computers would tell you that you can get a much more powerful laptop for what one of these minis cost new.. The person buying them is clueless and doesnt realize that they arent saving anything by buying new as these require lot tinkering and modifying to be truly useful, whether windows or linux. As they come out of box, they are set up to serve everybody else's desires for profit and marketing opportunities, BEFORE considering actual user needs. They have the super tiny storage drive to try and force people to the cloud and perpetual rent. Cloud just means you are paying rent for storage space on somebody else's computer. I can see maybe scans/copies of some important documents stored there in case of natural disaster or theft. Like a bank lockbox. But otherwise it makes little sense. Its not for the users benefit, its meant to squeeze out further profits and take more control out of hands of the user.


Posts : 227
Join date : 2014-07-09

View user profile

Back to top Go down

Acer Aspire One Cloudbook - A01-131-C7DW - 11.6"  Empty Re: Acer Aspire One Cloudbook - A01-131-C7DW - 11.6"

Post by Admin on Fri Jul 27, 2018 6:45 am

Ok this is actually about the 32GB Acer, but this applies to either since they have a Synaptics Touchpad.  This thing is trouble in windows, it worked for while with Puppy then got so I couldnt right click.

I thought the touchpad itself was bad, but not so.  You just have to do one or two modifications as mentioned here:

Right click on touchpad not working in Puppy Linux - FIX

Copied and pasted various things from forum at

The following worked for me:
It looks like your right button area has not been set. Try this:

Make a backup of your /etc/X11/xorg.conf file, then edit it as follows:

Look for a section that begins like this: Code:
Section "InputDevice"
   Identifier "Synaptics Mouse"
   Driver "synaptics"

There may or may not already be some options listed there.

Add these options before the EndSection line: Code:
  Option "ClickPad"         "true"
   Option "SoftButtonAreas"  "50% 0 82% 0 0 0 0 0"

Then restart the X server.
Well that seemed to fix the lack of scrolling but right click worked once after restart of X then stopped working :-\
OK, I see no Synaptics related errors in Xorg.0.log. And nothing in the synaptics driver configuration in xorg.conf looks like it would cause the problem you are seeing.

I've taken a look at the source code for the 1.6.2 synaptics driver, and there is definitely code in there to support setting "SoftButtonAreas".

So I am going to guess that it is being initialized properly, then being changed later.

The fact that it worked one time is consistent with that guess.

Please post the output of this command (note the leading dot and capital 'S' in the filename): Code:
cat /root/.flSynclient

Unless it says "No such file or directory", hide the file with this command: Code:
mv /root/.flSynclient /root/.flSynclient.hid

Then restart the X server. and try the button.

So, to sum up: Add the lines
Option "ClickPad"         "true"
   Option "SoftButtonAreas"  "50% 0 82% 0 0 0 0 0"
in the xorg.conf - file - and save it.
Restart graphical server and try it. (WORKS OKAY? COOL.)
IF it just works ONE time? -
Then you must hide the file flSynclient by writing the command:
mv /root/.flSynclient /root/.flSynclient.hid
- Then restart graphical server - voila :-)

Anyway basically hiding /root/.flSynclient file under different name did the trick for me.  I can right click again.


Posts : 227
Join date : 2014-07-09

View user profile

Back to top Go down

Back to top

Permissions in this forum:
You cannot reply to topics in this forum