StretchDog64, OpenShot 2.4.2, and PeasyWIFI 4.5

Go down

StretchDog64, OpenShot 2.4.2, and PeasyWIFI 4.5

Post by Admin on Tue Sep 18, 2018 5:11 pm

Yea they are all related. First I had wanted to try OpenShot. Its in AppImage format and couldnt do anything with it on any Puppy linux I found. All due to combination of it needing QT5 and some certain Python.

Anyway one person Mikesir on Puppy Form had mentioned in a post last spring that OpenShot 2.4.1 AppImage ran on StretchDog64. StretchDog 64 is a Puppy-like incarnation of Debian 9 "Stretch". So I download a copy. It wont boot on the Acer Aspire Cloudbook by the way. But boots on the old Dell that is now my wall computer after the Asus wouldnt boot after thunderstorm with lightening. Simple as booting from live cd of StretchDog and then plugging in thumb drive with the AppImage file that had been made executable. Bing bang boom, there is OpenShot in all its glory. Didnt do much yet with it other than play a bit to see how stable it is. Its stable. I will mention Mikesir said older version OpenShot 1.4.3 worked on Xenialpup64, but no such luck for me. I imagine he had some other added library or upgraded version or something he forgot about. But at this point not worried about it, I will just boot StretchDog64 and use it with latest OpenShot.

Now Stretch has this weird WIFI connection manager called PeasyWIFI. Unlike most current Puppies thats only WIFI connection offered and hard to add another without being able to connect its package manager to WIFI. You get the idea. Most Puppies by way dont use PeasyWIFI, its choice of three the most popular being Frisbee.

Its a homebrew script and gui thing that uses commandline tools to connect. Most of such WIFI managers are, some just require some huge libraries to support the gui decorations, they dont actually help in slightest in the actual connection. Well PeasyWIFI has to have the least intuitive gui ever. It saw my open network (ST hotspot) but continual "connection failed". After reading deep into the 18 page PeasyWIFI development thread on Puppy forum, I first downloaded pet package of version 4.6, the last one and installed it on experimental instance of Xenialpup64 so I wouldnt screw up my daily use one. It installed and gui popped up. Seems in my case I need to make a profile and this profile specifically needs the little checked box unchecked, the one that says scan ssid=1. My ST hotspot needs this to be zero, not one. Unchecking the box does this. After that with profile created that meets my exact setup, I restart PeasyWIFI and click to connect. It does. Surf a bit. Click disconnect. It does. Reboot, it remembers my profile and easily connects.

Then tried Stretch again and create a proper profile on PeasyWIFI 4.5 built into it. Again it connects, and disconnects, no drama. The 4.6 version did seem bit crisper and more responsive, but maybe thats cause I was running Stretch from livecd??? The big upside of PeasyWIFI, it is small, no monster libraries for eyecandy, etc, and it works. It can be used manually or set up to automatically connect. Beats the others for manual use by way, once profile is set up correctly its just connect/disconnect, easy at that point. The big downside, its not very intuitive to set up that first time. Now if you have router that needs scan ssid=1, then hey its whole lot easier, you probably could even just scan and connect without even setting up a profile since scan ssid =1 is the default.

Admin
Admin

Posts : 147
Join date : 2014-07-09

View user profile http://homesteadtinkerer.forumotion.com

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum